Build tools for Unix

From Doomsday Wiki
Jump to: navigation, search

This article is a stub. You can help by expanding it.

This information needs to be updated for the use of qmake.

Ubuntu

First, make sure you have the universe and multiverse repositories enabled on your Ubuntu system.

Next make sure you have the toolchain installed to build Doomsday. You will need: GCC, Python, Git, and Qmake. Install them like this:

sudo aptitude install build-essential python git qt4-qmake qt-creator

Now that the toolchain has been installed, you will now need to install the development libraries. These are SDL, SDL mixer, zlib, libpng, OpenAL, OpenGL, ncurses, X11, and the dynamic loader. Install them like this:

sudo apt-get install libltdl3-dev libsdl-mixer1.2-dev libsdl1.2-dev libpng-dev libopenal-dev zlib1g-dev libncurses5-dev libx11-dev libxext-dev libgl1-mesa-dev libglu1-mesa-dev libxxf86vm-dev

Now, I suggest a good syntax highlighting text editor. If you prefer an console application I recommend the Midnight Commander, and if you prefer X11, I suggest Gedit. Install Midnight Commander like this:

sudo aptitude install mc

or Gedit like this:

sudo aptitude install gedit

Debian

See instructions for Ubuntu. Instructions for Ubuntu are often applicable to Debian Unstable.

Fedora

Note: These directions are for the i386 build of Fedora Core 6, however these instructions should work on FC5.

The easiest way to obtain and install the necessary libraries is by invoking yum via the terminal:

yum install cmake SDL_mixer SDL_net openal mesa-libGL-devel mesa-libGLU-devel
yum install SDL-devel SDL_net-devel SDL_mixer-devel zlib-devel libpng-devel
yum install graphviz ncurses-devel

Each package can be installed in one single (and long) command, however I divided it in to 3 seperate ones for legibility reasons. This should provide all the necessary libraries for a standard Fedora Core 6 install and anything else one might require can be obtained in the same way in case something is missing.

Gentoo

Since you're running Gentoo, you certainly have a working toolchain already. We'll start by installing the requisite tools:

emerge -nav zip git cmake

In order to build doomsday you must have the following packages installed: sdl-mixer, sdl-net, openal, libsdl, libpng, mesa, libX11, zlib, and ncurses. Assuming you have a working X.org install you surely have all except possibly the first 3 or 4 of these installed. Simply emerge any which are missing from your system.

See also